SL on raspberry pi freezes jackd

Problems getting SL up and running on Linux? Post here.

Moderator: jesse

Post Reply
emillo
Posts: 1
Joined: Tue Oct 17, 2017 7:45 pm

SL on raspberry pi freezes jackd

Post by emillo »

Hello,

first post here although is a while that I use this wonderful software (https://www.youtube.com/watch?v=3nUFJfASYjM)

Now, I bought a raspberry pi and a new soundcard specially made for it called pisound (http://blokas.io). I'm running debian stretch on it and jackd -V reports

Code: Select all

jackdmp 1.9.11
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2014 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
jackdmp version 1.9.11 tmpdir /dev/shm protocol 8
Sooperlooper works wonderfully even at low jack periods (128), the sound is cristal clear and all is as it should be, BUT
sometimes sooperlooper starts to emit continuously the got xrun message and jackd freezes completely without any printed error on the console. No more connections are possible to the dead jackd, the only option at this point is to kill both SL and jack.

I've never had this problem on my previous uses of SL on normal pc so I suspect it may be related to the different architecture... any hints on what could I check? jack settings that can avoid this problem? different jackd version or build with different parameters? I'm very close to the perfect portable looper (currently paired with a novation remote zero) but this is a real showstopper :(

Thanks in advance for your attention

GregWard
Posts: 3
Joined: Tue Jul 24, 2018 9:08 am

Re: SL on raspberry pi freezes jackd

Post by GregWard »

Did you ever solve this?

colinbrogan
Posts: 24
Joined: Thu Oct 25, 2018 8:15 pm

Re: SL on raspberry pi freezes jackd

Post by colinbrogan »

Also looking for a solution to this. I am also on a Raspberry Pi, running a realtime kernel. I can launch Sooperlooper and jackd without the XRun error, but the second I try to connect to it with OSC via python, it gives me an infinite loop of the console outputting "got xrun". If anyone even has an insight into what that message means, I will try as many things as possible to find a workaround. I am also working on a self-contained looper pedal. This problem, if not solved, could grind to a halt a very promising project entirely.

colinbrogan
Posts: 24
Joined: Thu Oct 25, 2018 8:15 pm

Re: SL on raspberry pi freezes jackd

Post by colinbrogan »

In case anyone on this thread still has any interest in solving this problem, or if anyone else chances on this thread looking for a solution, I was able to get rid of this message.

There are a few posts suggesting this problem can arise with hostname issues. Here is one such post:

http://www.essej.net/slforum/viewtopic.php?p=40#p40

I don't know what anyone's setup is here posting, but I ran "hostname" on my machine, and then replaced my OSC server's (I am running a custom python script to connect to sooperlooper) name to be the output of that command, and the got xrun errors went away. The above post suggests a solution when using slgui.

Post Reply