Version 1.6.12 Released

Release announcements and other news

Moderator: jesse

Version 1.6.12 Released

Postby jesse » Mon Dec 22, 2008 2:21 am

This release is a result of going through the mailing list and forums picking out the low hanging fruit to fix and implement. If I missed yours, please let me know. Items I have not yet been able to reproduce are probably not fixed yet.

http://essej.net/sooperlooper/download.html

Fixes in this version:

  • removed debug printout that was causing CPU over-usage

  • fixed behavior when loading sessions, loops start paused, and empty loops remain empty

  • attempt to further ensure that the loops really pause on midi stop reception

  • fixed issue in AU plugin where no audio was being output even though it looked like it should have been. This occurred in some hosts when the input to the plugin was silent.

New features:

  • Added option to send MIDI start event on a loop trigger (for the sync source loop). See the Preferences-> Misc tab. Also note that turning on MIDI clock output control has moved there too.

  • Added keyboard bindings for missing commands (including next/prev loop selection)

  • Added record_or_overdub command. This command will act like 'record' when there is no loop (eg, at the beginning or after an undo_all), otherwise it will act like 'overdub'.

  • Added control for allowing replace/subs to ignore quantize setting. Similar to the same option for overdub, it is called replace_quantized and is in the GUI at the top as 'repl quant'. When quantize is set and 'repl quant' is enabled, it acts as it always has. But if 'repl quant' is disabled, replace and substitute commands will never be quantized.

  • Added ability to launch/load SL session files from the Mac OS X Finder by double-clicking, or dragging onto dock icon.

PS:
I was not yet able to reproduce the strange GUI starting issues some people are having inside Live. I hope to get more feedback from folks about that.

jlc
jesse
 
Posts: 479
Joined: Sat Sep 06, 2008 9:46 am

Re: Version 1.6.12 Released

Postby sam_square » Mon Dec 22, 2008 7:41 pm

The filetype binding is working great in OS X - within Mainstage and standalone.

I'm still getting the same behavior when opening files though - with the recording and playing. The loops are also out of time until all loops play through once. Let me know if I can help out in anyway.
sam_square
 
Posts: 58
Joined: Thu Nov 13, 2008 1:28 am
Location: phoenix, AZ


Return to News

Who is online

Users browsing this forum: No registered users and 1 guest

cron