Midi bindings: CC On and Off reversed

Report anything that appears to be a bug here.

Moderator: jesse

Midi bindings: CC On and Off reversed

Postby meznom » Wed Oct 16, 2013 1:43 am

The behaviour of CC on and CC off seems to be reversed or at least unintuitive.

In preferences -> midi bindings:
  1. create new binding for command `select_next_loop`, global
    • cc on: command gets triggered, whenever the value changes from !=0 back to 0 (i.e.
      when it's a button whenever the button is released)
    • cc off: command gets triggered for all value changes, except when it is
      changed to 0 (in case of a button that sends 0 and 127: whenever the button
      is pressed)
  2. create a new binding for command `record`, selected loop
    • cc on: does never trigger the command
    • cc off: does trigger for all value changes, except when the value is changed to 0
meznom
 
Posts: 2
Joined: Wed Oct 16, 2013 1:15 am

Re: Midi bindings: CC On and Off reversed

Postby kasbah » Mon Oct 21, 2013 8:34 am

Yes, it does seem reversed.

I think it got by me because I generally bind CCs to CMDs using just CC and not On or Off. And only use CC On and Off for CTRLs that I want to toggle. So that is actually the work-around for now since plain old CC will work fine for CMDs.

EDIT: It was a quick fix so it should be in the next release. There is still some weirdness as CCoff doesn't seem to work at all.

EDIT2: They CC Off and Note Off bindings don't really behave as expected on CMDs. They are basically ignored. Might break people's set-up if I fix that though.
kasbah
 
Posts: 117
Joined: Tue Sep 06, 2011 7:01 pm

Re: Midi bindings: CC On and Off reversed

Postby Pekka » Tue Mar 03, 2015 12:29 pm

Just to add this old thread:

Using SL 1.7.3 and CC commands don't work like they should. I'm using KORG nanoKONTROL2 as controller and it sends CC value 127 when pressed and value 0 when released. SL reacts to these both, for example starts recording on press and stops recording on release. There seems to be workaround to select "CC Off" (seems still reversed!) from SL but then long press/press twice commands don't work. And I can't select "SUS" option when using CC commands...? It's a shame that SL has this kind of bugs.. I really like it otherwise.

EDIT: But if I use old Midi binding file from SL 1.6.8 it works otherwise but not long presses etc.. This is weird.
Pekka
 
Posts: 21
Joined: Tue Dec 09, 2014 12:24 pm

Re: Midi bindings: CC On and Off reversed

Postby deegio » Sat Mar 19, 2016 10:21 am

Hey pekka!

I have the same problem and it's a big one especially with the controllers (like pads) which cannot be turned as toggle controls but are forced momentary. I was using the 1.7.3, fortunately my new distro is plugged with a 1.7.0 but i didn't get the chance to test it yet (i will test it this weekend) but i'll keep you posted if the 1.7.0 doesn't have that bug.
I hope it works because i don't wanna come back to the 1.6.18 (which had some tricky bugs)

Anyway, where are you kasbah, seems that you haven't been here for a while, hope everything's fine!
Don't hesitate to tell me if you get back to coding i would be more than pleased to test/help in any way possible (i don't know how to code though)

Thank you for your work since jesse was busy somewhere else!
deegio
 
Posts: 5
Joined: Sat May 05, 2012 5:37 am


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron