MIDI STOP can cause Crash

Report anything that appears to be a bug here.

Moderator: jesse

Post Reply
josh
Posts: 9
Joined: Thu Mar 29, 2012 2:13 am

MIDI STOP can cause Crash

Post by josh »

Seems like if you send more than one (or possible too many...) Midi Stop messages, than Sooperlooper will crash (the backend crashes and the GUI looses connection).

kasbah
Posts: 117
Joined: Tue Sep 06, 2011 7:01 pm

Re: MIDI STOP can cause Crash

Post by kasbah »

What do you mean by MIDI stop? A note-off? Could you give more details please as to what exactly you are sending and what SL outputs to terminal when crashing?

jesse
Posts: 530
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: MIDI STOP can cause Crash

Post by jesse »

He means the beat clock stop message: 0xFC.

Josh, what platform and what settings are enabled (especially the ones in the misc preferences)?

josh
Posts: 9
Joined: Thu Mar 29, 2012 2:13 am

Re: MIDI STOP can cause Crash

Post by josh »

I'm using Ubuntu 64bit Lucid Lynx. I'll have to get back to you on the settings, I'm not at that computer right now. But off the top of my head, I know Sooperlooper is synced to Midi Clock and nothing else (it's not synched to Jack or controlling Jack). Honestly, this was only a problem because my software wrapper was buggy and sending more Midi Stops then it needed to and I fixed that, so not a show stopper. I'll try to get those settings soon though.

josh
Posts: 9
Joined: Thu Mar 29, 2012 2:13 am

Re: MIDI STOP can cause Crash

Post by josh »

I hope this doesn't post twice, but the last attempt didn't seem to work. Also, I should add, that this this happens every time, not a random kind of thing. If Sooperlooper receives two MIDI Stop events before receiving a MIDI Start, it crashes:

Ok, more details.

Under Latency/Misc...

Automatically set Latency... checked
Automatically Disable... checked
Pause all loops on incoming MIDI Stop Event... checked

On Main screen

sync to: MidiClock
8th/cycle: 8
quantize: cycle
mute quant, odub quant, repl quant: checked

sync, playback sync: checked on all loops (four)

Hope that helps!

Post Reply